ignored_portion=0 problem

Moderators: michael_borland, soliday

Post Reply
Olga Konstantinova
Posts: 4
Joined: 23 Aug 2013, 03:50

ignored_portion=0 problem

Post by Olga Konstantinova » 26 Aug 2013, 19:59

Dear Michael,

I am running Touschek scattering routine with ignored_portion=0, but it crushes (see attached log file).
Do you have any idea why does it happen?

And also one more comment. I fixed a bug for touscheckScatter.c according with the following:

Line 549
weight_ave = tsptr->totalWeight/tsptr->simuCount
tsptr->simuCount : number of lost particles

If it is 0, the code crashes. It occurs frequently when a loss rate is low.
I think a corrected the line as follows:

If (totalWeight/tsptr->simuCount >0)
weight_ave = tsptr->totalWeight/tsptr->simuCount;
else
weight_ave = tsptr->totalWeight;

Olga A. Konstantinova, KEK
Attachments
ele-ip0.00-5e6-0.log
(75.46 KiB) Downloaded 129 times

michael_borland
Posts: 1801
Joined: 19 May 2008, 09:33
Location: Argonne National Laboratory
Contact:

Re: ignored_portion=0 problem

Post by michael_borland » 16 Sep 2013, 08:35

Olga,

Thanks, I've alerted the author of Touschek routines to this problem.

--Michael

xiaoam
Posts: 17
Joined: 12 Jun 2008, 09:27

Re: ignored_portion=0 problem

Post by xiaoam » 16 Sep 2013, 11:34

Olga,

I couldn't repeat your problem, please send me your input file.
The tsptr->simuCount shouldn't be a problem. The code simulate a maximum
181818182 events automatically. If there is none of them exceed the momentum
acceptance, there is no need to do this simulation. In your case, you got 4 M particles
for tracking. I will add a bumb message so people knows they should ignor touschek
in such a case.

aimin

Olga Konstantinova
Posts: 4
Joined: 23 Aug 2013, 03:50

Re: ignored_portion=0 problem

Post by Olga Konstantinova » 25 Sep 2013, 03:36

Dear aimin,

Thank you for your reply. Here are my input files. I will be very glad if you fix this problem.

Olga.
Attachments
Input files Olga.zip
(65.98 KiB) Downloaded 131 times

xiaoam
Posts: 17
Joined: 12 Jun 2008, 09:27

Re: ignored_portion=0 problem

Post by xiaoam » 28 Oct 2013, 22:59

Olga,

I don't have problem for testing, see attached file.
While the difference could be:
1. You gave me a wrong .lte file which I am not repeating the exact situation as you encounted.
2. I only tracked 1 TSCATTER element for saving time (maybe saving memory also).
you can separate your run into sub-step run by setting i_start and i_end in the code.
3. You tracked Touschek scattered particles through CSR effect evoked elements, which might generate other problems.
Try turn off those effects. Touschek particals have weight associate with them. They are not present as same as the
normal bunched particles.

You can send me the .lte file which causing the problem, or you can test 2 or 3 by yourself.

Regards,

aimin

xiaoam
Posts: 17
Joined: 12 Jun 2008, 09:27

Re: ignored_portion=0 problem

Post by xiaoam » 28 Oct 2013, 23:01

Sorry, forget the attachment.
Attachments
Olga-Test-Result.zip
(158.58 KiB) Downloaded 120 times

Olga Konstantinova
Posts: 4
Joined: 23 Aug 2013, 03:50

Re: ignored_portion=0 problem

Post by Olga Konstantinova » 22 Nov 2013, 03:07

Dear aimin,

Sorry for the confusion with the lattice file.
I attached the correct set of the input data.

1). Yes, I am sorry for this sad mistake.
2). Would you please simulate at least for 40 TSO, because the code typically crashes somewhere about TSO#30 (The total number of TSO is 616) . As far as I believe this is "divided by zero problem".
3). Thank you very much. This I will try.

Sincerely yours,
Olga.
Attachments
Input files Olga (Improvements).zip
(64.84 KiB) Downloaded 135 times

Post Reply