Setting Expand_Hamiltonian to 1 of a CSBEND

Moderators: michael_borland, soliday

Post Reply
duanz
Posts: 49
Joined: 30 May 2009, 01:50

Setting Expand_Hamiltonian to 1 of a CSBEND

Post by duanz » 29 Sep 2019, 03:05

Hi Michael,

It appears that setting expand_hamiltonian to 1 of a CSBEND produces incorrect result during tracking, for the latest 2019.2.1 version. In the attached example, we compared the results of tracking a particle through a CSBEND w/ expand_hamiltonian set to 1 and 0 (default value), a nontrivial difference in the x dimension is observed.

Best,

Zhe
Attachments
simple.tar.gz
(818 Bytes) Downloaded 180 times

michael_borland
Posts: 1800
Joined: 19 May 2008, 09:33
Location: Argonne National Laboratory
Contact:

Re: Setting Expand_Hamiltonian to 1 of a CSBEND

Post by michael_borland » 01 Oct 2019, 22:24

Zhe,

You are correct, this is a bug. I used a very simple-minded (inaccurate) integration scheme in this case. I hope to have a better scheme implemented in the next release.

Thanks for reporting the problem.

--Michael

michael_borland
Posts: 1800
Joined: 19 May 2008, 09:33
Location: Argonne National Laboratory
Contact:

Re: Setting Expand_Hamiltonian to 1 of a CSBEND

Post by michael_borland » 07 Oct 2019, 13:56

Zhe,

This bug was fixed in the 2019.3.0 release (just now available).

--Michael

duanz
Posts: 49
Joined: 30 May 2009, 01:50

Re: Setting Expand_Hamiltonian to 1 of a CSBEND

Post by duanz » 08 Oct 2019, 10:38

Hi Michael,

I just downloaded the latest version of elegant, and now the bug is gone. Thanks for your kind help!

Best,

Zhe

Post Reply