plotting 2-D while scanning 1 variable

Moderators: cyao, michael_borland

Post Reply
jtobin
Posts: 47
Joined: 23 Jul 2008, 15:00

plotting 2-D while scanning 1 variable

Post by jtobin » 26 May 2015, 23:12

Michael and elegant users,
So if I scan a single variable (RF phase) and want to look at the bunch centroid say then I do

Code: Select all

sddsplot -graph=symbol,scale=2 -parameter=CAV.PHASE,Cx run.fin 


but how do I

1. plot longitudinal phase space (2-D) as a function of a single scanned variable (RF phase) with colors as legend for the scanned phases. My scans are generally limited to 5 or 6 values.

and/or

2. plot 1-D projections say the energy profile as a function of RF phase.

This would be terrific in understanding and visualizing results. I am assuming about 10K particles. Thanks!

Charles

ps: Are the results stored in pages? If so, how I can use it?

michael_borland
Posts: 1796
Joined: 19 May 2008, 09:33
Location: Argonne National Laboratory
Contact:

Re: plotting 2-D while scanning 1 variable

Post by michael_borland » 27 May 2015, 12:33

Charles,

Attached you will find an example run that shows how to do both of these things.

The data from each step does go into another page, which helps to keep things organized.

--Michael
Attachments
scanParameters2.tar
(10 KiB) Downloaded 645 times

jtobin
Posts: 47
Joined: 23 Jul 2008, 15:00

Re: plotting 2-D while scanning 1 variable

Post by jtobin » 28 May 2015, 13:00

Michael,
Thank you very much. This was what I was looking for. But a minor hiccup, it (sddshist actually) keeps reporting invalid lowerlimit. Separately running the sddscombine does print out a valid value. I don't know what is the problem. Any ideas? May be the cygwin environment is not suited.
But I can live with this. Right now I just set the lower limit manually.

-Charles

michael_borland
Posts: 1796
Joined: 19 May 2008, 09:33
Location: Argonne National Laboratory
Contact:

Re: plotting 2-D while scanning 1 variable

Post by michael_borland » 28 May 2015, 14:48

Charles,

Yes, that is certainly a cygwin limitation. Another option on Windows machines is to run linux in a virtual machine.

--Michael

Post Reply