Synchrotron radiation and rf system

Moderators: cyao, michael_borland

Post Reply
austinjdick
Posts: 2
Joined: 01 Apr 2021, 08:05

Synchrotron radiation and rf system

Post by austinjdick » 19 Oct 2021, 09:34

Hello all,

I am seeing some strange long-term longitudinal behavior that I believe is related to the rf-system and SR effects. I am running simulations of ~1e7 turns and am seeing damping in the transverse emittance. However, the bunch length grows over the entire simulation to a value much larger than the expected equilibrium value.

I believe the issue is coming from my implementation of the rf system and SR effects. The SR is computed in the dipoles using the CSBEND element with the synch_rad parameter set to 1. I previously used the SREFFECTS element in the lattice but have removed it because my understanding is that it will produce a double counting of the SR effects. The RFCAVITY element is defined in the lattice file by length only and the rest of the parameters (voltage, harmonic, and frequency) are set using the rf_setup function in the command file.

Is there an error in the way I am implementing either of these elements that would explain the longitudinal behavior? I have attached the elegant file and some plots of the behavior I am describing.

Thank you in advance,
AJ Dick
Attachments
emit.png
bunch_length.png
IOTA_OSC.ele
(730 Bytes) Downloaded 55 times

michael_borland
Posts: 1796
Joined: 19 May 2008, 09:33
Location: Argonne National Laboratory
Contact:

Re: Synchrotron radiation and rf system

Post by michael_borland » 20 Oct 2021, 08:56

AJ,

Did you also set ISR=1 on the CSBEND elements? If not, there's no quantum excitation and you'd see the initial emittance damp away.

--Michael

austinjdick
Posts: 2
Joined: 01 Apr 2021, 08:05

Re: Synchrotron radiation and rf system

Post by austinjdick » 25 Oct 2021, 08:49

Hi Michael,

Thank you for the information on the ISR, I did not have this turned on. This did not resolve my issue but I believe it was caused by the rf cavity. I set the change_t parameter to 1 and am seeing results more in line with what I expected. Thanks again.

-AJ

Post Reply