Big difference results between KQUAD and QUAD

Moderators: cyao, michael_borland

Post Reply
Cai_Meng
Posts: 17
Joined: 19 Jun 2017, 08:01

Big difference results between KQUAD and QUAD

Post by Cai_Meng » 14 May 2021, 03:45

Dear Elegant experts,

when I designed an achromatic lattice, there are big difference results between KQUAD and QUAD lattice with "default_order=3". Although, two lattice have same "etay" (*.twi) , the simulation results with QUAD-lattice looks good, but the simulation results with KQUAD-lattice show that the R36 sames not zero (*.sig & *.out). The results and lattice file are presented as attachments. Could you give me some suggestions? Are there some unreasonable settings ?

Thank you very much!

Best regards,
Cai
Attachments
Results.rar
(25.39 KiB) Downloaded 286 times
QUAD.rar
(2.12 KiB) Downloaded 288 times
KQUAD.rar
(2.12 KiB) Downloaded 283 times

michael_borland
Posts: 1796
Joined: 19 May 2008, 09:33
Location: Argonne National Laboratory
Contact:

Re: Big difference results between KQUAD and QUAD

Post by michael_borland » 14 May 2021, 10:53

Cai,

You need to use more slices for the KQUAD elements to get accurate integration. The defaults are rarely sufficient.

Try changing

Code: Select all

KQUAD,...
to

Code: Select all

KQUAD,INTEGRATION_ORDER=6,N_SLICES=10,...
I did this and the agreement on s36 was essentially perfect.

--Michael

Cai_Meng
Posts: 17
Joined: 19 Jun 2017, 08:01

Re: Big difference results between KQUAD and QUAD

Post by Cai_Meng » 16 May 2021, 20:29

Hi Michael,

Thanks very much! It does work after increasing the value "N_KICKS".

Best regards,
Cai

Post Reply