Search found 371 matches

by soliday
16 Jun 2009, 10:17
Forum: Installation
Topic: Upgrading to Elegant22
Replies: 4
Views: 51192

Re: Upgrading to Elegant22

I believe I found the problem. Prior to the last release I updated my compiler to Microsoft Visual C++ 2008 Express Edition and it turns out that I need to distribute msvcr90.dll in all releases now. There is a new version of SDDS ToolKit and Elegant on the web page now that includes this DLL.
by soliday
15 Jun 2009, 15:40
Forum: Parallel Elegant
Topic: Example install of Pelegant from source ... and questions
Replies: 7
Views: 14944

Re: Example install of Pelegant from source ... and questions

I have built and run Pelegant with openmpi-1.2.7. I was not able to make a static version but if your system is similar to our Fedora 5 64bit system you may be able to use it. It is at http://www.aps.anl.gov/asd/oag/downloads/Pelegant_64bit_openmpi-1.2.7 When I look at what libraries it links to I s...
by soliday
15 Jun 2009, 09:23
Forum: Installation
Topic: SDDS installation on Scientific Linux CERN release3.04
Replies: 2
Views: 31015

Re: SDDS installation on Scientific Linux CERN release3.04

Scientific Linux 3.04 is derived from Redhat Enterprise Linux 3. We do not build for this target so you will probably either have to build it directly from the source code or update to a more recent version of Scientific Linux.
by soliday
15 Jun 2009, 09:12
Forum: Installation
Topic: Upgrading to Elegant22
Replies: 4
Views: 51192

Re: Upgrading to Elegant22

Try uninstalling elegant and SDDSToolKit and then reinstall them.
by soliday
11 Jun 2009, 16:44
Forum: Parallel Elegant
Topic: Example install of Pelegant from source ... and questions
Replies: 7
Views: 14944

Re: Example install of Pelegant from source ... and questions

I downloaded openmpi-1.2.7 and built it using the default options. I then built Pelegant against it. I also am seeing issues with it under openmpi. But the error message is different: [max15:25834] *** An error occurred in MPI_Bcast [max15:25834] *** on communicator MPI_COMM_WORLD [max15:25834] *** ...
by soliday
10 Jun 2009, 16:21
Forum: Parallel Elegant
Topic: Example install of Pelegant from source ... and questions
Replies: 7
Views: 14944

Re: Example install of Pelegant from source ... and questions

I see a lot of the issues you are having are with the 64 bit paths. It would probably be useful to post what flavor of Linux you are using so I could setup a test computer to try to fix the build rules without having to create symbolic links to work around these issues. LAPACK and BLAS are available...
by soliday
10 Jun 2009, 16:00
Forum: Installation
Topic: Upgrading to Elegant22 and SDDS Version June 4, 2009
Replies: 4
Views: 50011

Re: Upgrading to Elegant22 and SDDS Version June 4, 2009

What version of libpng3 do you have installed?

Here is what fink says on our development machine.
libpng3 1:1.2.35-2 PNG image format handling library
libpng3-shlibs 1:1.2.35-2 Shared libraries for libpng3 package
by soliday
10 Jun 2009, 14:15
Forum: Installation
Topic: Upgrading to Elegant22 and SDDS Version June 4, 2009
Replies: 4
Views: 50011

Re: Upgrading to Elegant22 and SDDS Version June 4, 2009

Try installing the fink packages: openmotif4 and openmotif4-shlibs
by soliday
08 Jun 2009, 12:56
Forum: Parallel Elegant
Topic: Prebuilt versions of Pelegant
Replies: 0
Views: 6413

Prebuilt versions of Pelegant

I just wanted to note that Pelegant is now included in the Windows, Linux, and Mac distributions. It is built against MPICH2-1.0.8p1 with the default configuration.
by soliday
20 Apr 2009, 09:56
Forum: General
Topic: "mpl_motif.exe has stopped working" message
Replies: 2
Views: 1957

Re: "mpl_motif.exe has stopped working" message

Are you saying the plot crashes right away and you never see it? Or are you saying that it crashes when you go to save it? First I would rerun the SDDSTookKit installer and select "Remove". Once that is finished run the installer again to reinstall it. If this doesn't solve it, can you go to C:\Prog...