Search found 368 matches

by soliday
21 Nov 2022, 11:17
Forum: Installation
Topic: Compilation with epics base 7
Replies: 3
Views: 96

Re: Compilation with epics base 7

What is -I/---/elegant.2022.2.0/elegant_compilation/epics/extensions/include
When I build I see -I../../../../../../epics/extensions/include

Look at your oag/apps/configure/CONFIG file and make sure the EPICS_BASE and EPICS_EXTENSIONS are set properly
by soliday
18 Nov 2022, 11:12
Forum: Installation
Topic: Compilation with epics base 7
Replies: 3
Views: 96

Re: Compilation with epics base 7

Try editing epics/base/configure/CONFIG and add the following:
OPT_CXXFLAGS_YES += -std=gnu++11 -D_GLIBCXX_USE_CXX11_ABI=0

We have a mixed RHEL7 + RHEL8 environment here. To get it to work on both systems, I have to compile on RHEL7 with this option set.
by soliday
03 Jun 2022, 09:50
Forum: General
Topic: makeWigglerFromBends script on Windows
Replies: 2
Views: 2281

Re: makeWigglerFromBends script on Windows

Look in the same directory elegant.exe is in. The default path would be:
C:\Program Files\APS\Elegant x64\makeWigglerFromBends

This script will require ActiveTcl, OAG Tcl/TK and Cygwin also be installed. Then run from inside of a Cygwin command-line terminal.
by soliday
03 Jun 2022, 09:31
Forum: Installation
Topic: sddsplot issue in macOS 10.14
Replies: 8
Views: 13736

Re: sddsplot issue in macOS 10.14

Well my first suggestion would be to try to download and run the pre-compiled MacOS binaries for SDDS. I have taken care of ensuring to link to as many static libraries as possible to avoid the issues similar to what you are seeing. As for Print.h, I have a copy that I think was installed with openm...
by soliday
01 Jun 2022, 18:17
Forum: Installation
Topic: sddsplot issue in macOS 10.14
Replies: 8
Views: 13736

Re: sddsplot issue in macOS 10.14

System: MacOS Mojave 10.14.6 Intel CPU XQuartz 2.8.1 MacPorts 2.7.2 openmotif 2.3.8 Results from "otool -L mpl_motif" verify it is using the X11 libraries from /opt/X11/lib which is where XQuartz puts them and not /opt/local/lib which is where MacPorts has it's own versions. Previously it required D...
by soliday
01 Jun 2022, 14:26
Forum: General
Topic: Highlighting mode for emacs and vim
Replies: 10
Views: 3576

Re: Highlighting mode for emacs and vim

I have a script that searches the code for the highlightable elements and commands and updates the configuration files you made. The resulting files will be in the elegant/editors/ directory with the next release with instructions on how to install them for emacs and vim.
by soliday
10 May 2022, 09:03
Forum: Installation
Topic: sddsplot issue in macOS 10.14
Replies: 8
Views: 13736

Re: sddsplot issue in macOS 10.14

I believe this workaround is no longer required. However I don't have access to my MacOS laptop till next Monday so I can't confirm this. I'll make a note to check when I get back.
by soliday
06 May 2022, 09:28
Forum: Bugs
Topic: gpuElegant results not matching elegant
Replies: 1
Views: 2170

Re: gpuElegant results not matching elegant

I build gpu-elegant with CUDA 10 due to an issue with the output when built with CUDA 11. I looked into this a while ago but failed to identify the issue and haven't had time to look at it again. There are other issues with gpu-elegant as you have seen, and it should only be used when you can verify...
by soliday
28 Mar 2022, 12:00
Forum: Installation
Topic: Examples
Replies: 1
Views: 2454

Re: Examples

The command is: ./runMe You will need the tcsh cygwin package installed to run this script without editing it. If you continue to have trouble with it, try running the commands inside the script by hand on the command line: elegant run.ele sddsplot -parameter=QF1.K1,Transmission run.fin -graph=sym s...
by soliday
10 Mar 2022, 11:57
Forum: Installation
Topic: Installing ELEGANT with CYGWIN
Replies: 4
Views: 3200

Re: Installing ELEGANT with CYGWIN

To get to c:\ inside of cygwin, you have to go to /cygdrive/c Your download is probably in /cygdrive/c/Users/<username>/Downloads/ But you are looking at the source code here. I do not recommend compiling it yourself. You should instead download: https://ops.aps.anl.gov/cgi-bin/oagLog4.cgi?name=Eleg...